Author Topic: No Units Visible During Combat Fix  (Read 4857 times)

Offline Samu-kun

No Units Visible During Combat Fix
« on: April 30, 2014, 06:03:57 am »
Some players on older machines may not be able to see any units on the battle map. To fix this issue:

1. Press shift+g in the game.
2. Press "Force Angle/Direct X Renderer"
3. Restart game

Offline tocktickwait

Re: No Units Visible During Combat Fix
« Reply #1 on: June 19, 2014, 09:51:08 pm »
I've been using beta 3.1c, and I still can't see my units after applying this fix. I've also tried the other render options, but they didn't work either. Here is the traceback I get once I click end turn.

Offline Endershadow

Re: No Units Visible During Combat Fix
« Reply #2 on: June 19, 2014, 11:02:46 pm »
Have you already tried deleting all .rpyc files?

Please be careful not to fall into any holes in reality caused by my reality hole generator. If you do fall in though, I can assure you that there will be no adverse side effects except for the following: instantaneous mutation, loss of 1 or more vital organs, turning into banana pudding, amnesia, loss/growth of 1 or more limbs, additional vital organs, loss of DNA, insanity, hallucinations, destruction of the fabric of space and time, redundancy, redundancy, a craving for apples, the ability to see shinigami, for females: an erection lasting more than 4 hours, for males: extremely painful menstrual cramps, testicular inversion, gender swapping, the urge to watch my little pony, and/or death

Offline tocktickwait

Re: No Units Visible During Combat Fix
« Reply #3 on: June 19, 2014, 11:49:55 pm »
Oh thanks. It's working now.

Offline Oreo_Blue

Re: No Units Visible During Combat Fix
« Reply #4 on: June 22, 2014, 01:41:16 pm »
Suddenly I've got the same problem.... No units visible on the battlefield.

Tried the shift+G fix... Doesn't work
Tried to delete all of the .rpyc files... Still doesn't work.
Click the "End Turn" button, error screen, reload, worked, then during the enemy turn, it's another error....

The video recording
Traceback file attached.
« Last Edit: June 22, 2014, 01:47:06 pm by Oreo_Blue »

Offline Vaendryl

Re: No Units Visible During Combat Fix
« Reply #5 on: June 22, 2014, 02:37:02 pm »
Suddenly I've got the same problem.... No units visible on the battlefield.

Tried the shift+G fix... Doesn't work
Tried to delete all of the .rpyc files... Still doesn't work.
Click the "End Turn" button, error screen, reload, worked, then during the enemy turn, it's another error....

The video recording
Traceback file attached.

traceback tells me it's a case of corrupted .rpyc files. you should try closing the game, deleting all .rpyc files and try the bytecode.rpyb as well. after that, restart the game.  I know you said you tried that already but there's no other advice I can give. I can see code being run that really shouldn't be.
« Last Edit: June 22, 2014, 02:39:41 pm by Vaendryl »
(╯□)╯︵ uoıʇdǝɔxǝ
latest version: 7.2
RTFW
Mark 5:9

Offline Oreo_Blue

Re: No Units Visible During Combat Fix
« Reply #6 on: June 22, 2014, 03:03:10 pm »
Still doesn't work....

I load my saved game, and try to do the Battle of Tydaria, and got an error even before the battle map shown. Traceback file attached. I did tamper with the characters' graphic asset files, but I didn't change anything else. The game was also working fine yesterday. I wonder what caused this problem....

Offline Vaendryl

Re: No Units Visible During Combat Fix
« Reply #7 on: June 22, 2014, 03:18:22 pm »
Still doesn't work....

I load my saved game, and try to do the Battle of Tydaria, and got an error even before the battle map shown. Traceback file attached. I did tamper with the characters' graphic asset files, but I didn't change anything else. The game was also working fine yesterday. I wonder what caused this problem....

that crash seems different. it's not obviously caused by a faulty .rpyc file and it's just complaining a referenced variable doesn't exist. this is something that would happen if the save file compatibility code doesn't get run. as to why it would not be, I've no idea >.>
ever since patch 3.1 I've been seeing a lot of inexplicable stuff happen. I'm no stranger to obnoxiously obscure bugs but when things somethings work and sometimes don't it's nearly impossible to find a cause. especially when I never see these problems on my end. it also doesn't help that I know practically nothing about the black magic going on behind the scenes within ren'py itself. it's hard to tell if I'm doing something wrong or if there's a bug in ren'py that only shows up because I'm doing weird stuff nobody would want to try lol
« Last Edit: June 22, 2014, 03:22:56 pm by Vaendryl »
(╯□)╯︵ uoıʇdǝɔxǝ
latest version: 7.2
RTFW
Mark 5:9

Offline Oreo_Blue

Re: No Units Visible During Combat Fix
« Reply #8 on: June 22, 2014, 03:27:57 pm »
Well, luckily I've played it already, and I can just use the VN part to test my mod. Let's hope the next Beta won't have this problem :D.